Million Masterpiece
The One Million Masterpiece global arts project 32,614 artists
174 countries
community

Let's have a discussion.

The One Million Masterpiece | News, suggestions & bugs | [BUG] Problem with saving picture.

Page 1 of 212>
Author[BUG] Problem with saving picture.
smutnyleszek
Member

Posts: 8
Joined: 22.01.07

Posted on 25-06-2007 13:30
When I'm trying to save my new art, after a while the error message popups: "There was a problem saving your picture. Please check your internet connection and try again in one minute.". I checked my internet connection and tried one after another minutes - error appears every time :-(
I read in one topic by Alicia Thompson (January 21st), that there is a bug that appears "when complex pictures are created without intermediate saving". Seems like this is the same situation as mine.
Is there any chance the image can be saved? I will leave the FF window opened and wait for answer :-)
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Paul Fisher
Super Administrator

Posts: 277
Joined: 25.06.06

Posted on 25-06-2007 14:04
Hi,

We've just fixed a bug with the software within the last hour that might have fixed it - but the problem is that the software will have to reload to test it out. I'll try and find out if there is anything that can be done to save the image as it is...
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Eamonn
Super Administrator

Posts: 215
Joined: 24.06.06

Posted on 25-06-2007 15:48
It should be fine now - there was a reference in the saving script to a deleted db field, but not any more.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
smutnyleszek
Member

Posts: 8
Joined: 22.01.07

Posted on 25-06-2007 21:34
Nope - I can't save this image. It looks that I have to do a new one. I saved my work with PrintScreen and making process with HyperCam, so nothing is lost :-)
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Paul Fisher
Super Administrator

Posts: 277
Joined: 25.06.06

Posted on 25-06-2007 22:08
OK. Try clearing your cache so that the new drawing software is completely reloaded when you have another go.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
smutnyleszek
Member

Posts: 8
Joined: 22.01.07

Posted on 26-06-2007 22:03
Ok. I have another problem. When I was finishing my picture (I saved few times during work) a messagebox popuped asking me if I want to save or not. It was something about that I made too much work and I must save to continue. Ok, I clicked "save". Then after a while the same message, but when i clicked there was the same problem as in my first post ^. I clicked "undo" few times to come back to work-progress when the save worked and i saved the image. I closed the image editor and checked my gallery profile for this image I did. I was shocked - it saved only half of my work - the second half :-o So my image is without the details that i did on the beggining :-(
This new million masterpiece software seems to dislike me :-/

Here is the image: http://www.millionmasterpiece.com/gallery-543130?pic=25413
I started with sketch made with the smallest brush. Then i made details using this and next bigger brush. Here as You can see the replay starts with big blury shading that i did at the end of work.

Edited by smutnyleszek on 26-06-2007 22:18
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Eamonn
Super Administrator

Posts: 215
Joined: 24.06.06

Posted on 27-06-2007 12:21
The drawing software does some rather intricate processing whenever you reach a threshold of about 3000 brushstrokes, in order to ensure that the performance of the flash client is maintained. It involves communication between the user's machine and the server. My advice for now would be not to undo back accross this brushstorke threshold. I'll need to test and investigate the app.

If anyone else experiences a similar problem, please let me know.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Cassandra Tiensivu
Member

Posts: 1
Joined: 21.04.07

Posted on 03-07-2007 05:31
I'm also having saving issues. I redid my image today, saved it, and then came back later to redo it. The second version of the day saved, and when I went back to it later... both the first and second image had merged into one strange image. So I axed the thing again and tried for a third time. It won't save.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Jim
Super Administrator

Posts: 159
Joined: 30.11.06

Posted on 05-07-2007 06:43
AAAIIIIYEEE!!! noooo! I was drawing a whole new picture, first I drew the basic shapes and worked on from there. About halfway through I hit the "save" button and it saved my picture, So i decided to continue from that point by fine tuning the picture. When I saved it again, and then went to look at it, I was surprised to see that it replaced the original picture with one that only contained my most recent modifications. So in other words, most of the picture is gone, and only the fine tunings are left. Its my second picture if anyone wants to look at, but it looks like crap. I hope that it can be fixed, but I'm prolly going to have to work with what I have and redo the image.

Anyways, it seems like the problem is with the save feature, it expects the user to navigate away from the page after saving, rather, if they stay on the page, it will save over the image.
Send Private Message
AuthorRE: Me too.
Pip Hignett
Super Administrator

Posts: 213
Joined: 07.09.06

Posted on 05-07-2007 23:12
My gallery image seems not to have saved my latest changes also smiley

If the work is retrieveable then I will wait, but if not then I will re-do the work asap.

If you guys know the answer then let me know.

Thanks.

Pip.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Paul Fisher
Super Administrator

Posts: 277
Joined: 25.06.06

Posted on 06-07-2007 08:59
I know that Eamonn is looking in to this right now. Sorry for the bugs guys - this tool is so complex and is easily the most advanced online drawing tool out there so please bear with us!
smiley
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Pip Hignett
Super Administrator

Posts: 213
Joined: 07.09.06

Posted on 06-07-2007 09:47
Ok. Thanks, Paul.

I will wait for news before I attempt any more changes.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Eamonn
Super Administrator

Posts: 215
Joined: 24.06.06

Posted on 06-07-2007 12:44
Hi Pip - your image should be fine now. Sorry about that - it was nothing serious, one of our server daemons got a bit stuck. We have another daemon which rescues this one every time it gets stuck, which I'd temporarily switched off - it should be fine now though.

I made some minor modifications to the saving script yesterday and to the paint tool. A thorough test showed no problems so fingers crossed... Anyway I shall keep a close eye on it. Thanks to everyone for helping me spot these problems!
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Pip Hignett
Super Administrator

Posts: 213
Joined: 07.09.06

Posted on 06-07-2007 12:57
Yep yep. Everything seems just fine now.

Thanks for sorting this out. I'm sure I'm not the only one that's grateful to you for being on top of things and zapping those bugs.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Michelle Berggren
Member

Posts: 25
Joined: 07.04.07

Posted on 15-07-2007 02:28
i've been having problems saving my pics, when i press save a box pops up and says something like it couldnt save it because it was still processing my last save and to try again later. My last save was HOURS ago and i let it sit for 2-3 hours and came back and tryed to save it again and it still said the same thing.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Eamonn
Super Administrator

Posts: 215
Joined: 24.06.06

Posted on 15-07-2007 10:55
Sorry about that Michelle, one of the image processors got stuck again. I've restarted it manually so everything should be fine now, but I will of course look into why this happened and find a fix.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Aunty Mor
Member

Posts: 294
Joined: 28.12.06

Posted on 21-07-2007 20:05
Sorry to bother you Eamonn but when I save my latest changes it doesn't show up on the profile page but does when you press play.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Aunty Mor
Member

Posts: 294
Joined: 28.12.06

Posted on 23-07-2007 11:29
Ok, forget it. For some reason it has updated itself. Took 3 days though. Not sure what is going on there. May post again if it goes funny again.
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Aunty Mor
Member

Posts: 294
Joined: 28.12.06

Posted on 23-07-2007 11:43
Posting again! Redid it and saved and should be showing four white strokes but it is only showing two but when you replay it shows the four....Help pleasesmiley
Send Private Message
AuthorRE: [BUG] Problem with saving picture.
Eamonn
Super Administrator

Posts: 215
Joined: 24.06.06

Posted on 16-08-2007 15:21
Hi sorry for the late reply.... It should be okay now... There were some isssues with the image update software on the server dying periodically, but now it should be indestructable. If it happens again, however, do let me know! smiley
Send Private Message
Page 1 of 212>
Jump to Forum:
To reply to this thread, please Login or Register.










© 2006 - 2019 Million Masterpiece.
All rights reserved.
Home | About | View | Community | Shop | Login | Directory